Update, Crash und Recovery

(29.11.2017)

Server-Update

42er-Box Ludwigsburg (um 1990)

42er-Box Ludwigsburg (um 1990)

Eigentlich könnte EDV ja so einfach sein – wenn alles so laufen würde wie man will.

Nur meistens wollen die Geräte nicht so wie ich.

Der Plan:

vor ein paar Jahren habe ich mir eine Synology Diskstation DS1815+  gekauft. Da ich für Kunden Super8 und VHS-Filme überspielte und PCs reparierte (Platten-Images zwischenlagern) brauchte ich viel Platz, Für die Datensicherung auch noch was reserviert und schwups stand da eine Kiste mit 7x4TB. Das Ding lief 24h/7Tage die Woche und braucht natürlich viel Strom.

Die NAS- Installation war noch von der Vorgänger-Diskstation DS1512+ und da von der Vorgänger-Maschine.

Updates und Migration funktioniert bei den Kisten wirklich toll. Einfach Platten von der alten in die neue Maschine und dann bei Bedarf die Platten ersetzen – ist ja ein RAID-System: 1TB-Platte raus, 4TB rein, RAID wiederherstellen, nächste Platte. Und wenn alle durch sind das RAID auf den neuen Gesamtplatz vergrößern. Natürlich immer mit Datensicherung vor dem Umbau. Hat aber bisher immer geklappt.

Mit der Zeit liefen immer mehr wichtige und unwichtige Dinge drauf,  unter anderem mein Mailserver (Zarafa) und ausprobiert habe ich natürlich auch einiges. Es war also einiger Müll auf der Kiste.

Deswegen sollte es mal wieder ein sauberer Schnitt werden.

Also kein Plattentausch sondern komplette Neuinstallation.

Nach dem Umstieg von Zarafa (wurde leider nicht mehr für mich brauchbar für die Diskstation weiterentwickelt) auf den Mailserver+ von Synology  liefen nur noch unterstützte Standard-Dienste und damit sollte der Umstieg kein Problem sein.

In der verrückten Cyber/Black/Red-Week (auf Deutsch am besten mit Verramsch-Woche übersetzt) habe ich mir eine DS918+ geleistet und dazu 3x 8TB Festplatten.

Korrekt – eine kleinere Maschine mit größeren Platten. Mit Super8-Transfer mache ich nicht mehr so viel und EDV-Service garnicht mehr, daher brauche ich weniger Platz. 3x8TB im Raid 5 ergeben 16TB (Raid 5 = n-1, also 3x 8TB = 2x 8TB für Daten + 1x 8TB für Parity), da die Hersteller aber anders rechnen und auch etwas Verwaltungsoverhead benötigt wird sind es am Schluss knapp 14TB nutzbarer Kapazität. Das sollte ein Weilchen reichen.

Die kleinere Maschine sollte mit weniger Platten hoffentlich deutlich weniger Strom verbrauchen, durch die größeren Platten ist der Gesamtspeicher aber kaum kleiner als vorher. Dazu habe ich mir eine 250GB SSD als Cache-Medium gegönnt. Insgesamt fühlt sich das System damit deutlich reaktionsfreudiger an.

Die Übertragungsgeschwindigkeit wird jedoch kaum schneller, da ist das Gigabit-Netzwerk mittlerweile der begrenzende Faktor. Das wird dann die nächste Baustelle für 2018 oder 2019 – Umstieg auf ein  10GBit-Netz.

Eine Migration ist leider immer nur in die Richtung “größer” möglich, daher konnte ich das RAID mit 5 Platten aus der DS1815+ nicht direkt in die DS918+ übernehmen. Ausserdem wollte ich auf das neue BTRFS Dateisystem umstellen. Also gab es die Migration “von Hand”.

“Offener Versand”

In der Cyber-Week habe ich noch eine externe 8TB-Festplatte mitbestellt die von Amazon recht materialsparend verpackt worden ist. Ein Wunder daß das Teil überhaupt angekommen ist.  Aber DHL hat sich diesmal ganz gut geschlagen und daher hat ausser der Versandverpackung nicht viel gefehlt.

Ansonsten kann man bei 150,- Euro für 8TB mit USB3.0 nicht meckern. Für die Datensicherung passt das.

 

DS918+ zusammenbauen (Platten, 8GB extra RAM und 3x8TB einbauen) und installieren. Das ging nebenher und recht flott. Danach waren die Standard-Dienste installiert.

Da die alte Kiste bei mir “Diskstation” hiess was ab und an kleinere Probleme gab wenn ich eine neue “Diskstation” eingerichtet habe habe ich die DS918+ einfach “Server” genannt.

Und da beide Geräte parallel liefen konnte ich jetzt einfach meine Dateien von der einen Diskstation auf die andere verschieben. Das lief problemlos sogar im Produktionsbetrieb. Während der normalen Arbeit wurden im Hintergrund die Daten umgeschauftelt.

Mailserver, Kalender, Kontakte,  Squeeze-Server, alles musste auf die neue Maschine.

Da wir nur 2 Benutzer sind ging das bei den Mails, Kontakten und Kalendern am einfachsten über Outlook- Einfach altes und neues Konto parallel öffnen und die Daten vom alten ins neue Postfach verschieben.

Die Daten habe ich einfach von der einen Freigabe auf die andere kopiert.

Die Umkopiererei hat dann allerdings insgesamt schlappe 2 Tage gedauert. Waren halt doch einige Daten auf der Platte.

CRASH

Tja und dann wollte ich natürlich auch anfangen zu optimieren.

Als erstes habe ich schlauerweise alle Client-Sicherungen neu initialisiert und angefangen Sicherungen auf dem neuen Server anzulegen. 1. Rechner war mein uralter Windows-Server den ich schon seit einiger Zeit umstellen wollte – allerdings eigentlich nicht heute!

Backup erstellt, Updates installiert und dabei gewundert warum der nur eine Platte anzeigte.

Ich war eigentlich der Meinung daß ich da immer zusätzlich lokal gesichert habe. Eine lokale Platte für Daten, eine für die Sicherung. Es war aber keine Sicherungsplatte vorhanden.

Aber die Sicherung auf das alte NAS lief und auf dem neuen funktionierte jetzt auch. (ich sichere immer mindestens doppelt, besser dreifach).

17.50 war die Sicherung abgeschlossen, inclusive Virtueller Linux-Maschine für diese Webseite.  Die nächsten Tage wollte ich die Kiste mal aufschrauben und aussaugen und schauen ob die Sicherungsplatte defekt war oder ob ich die irgendwann mal ausgebaut hatte – heute aber eigentlich nicht.

Tja und dann habe ich Windows-Updates installiert, neu gestartet und weg war der Server.

Übers Netzwerk nicht mehr erreichbar.

Das Ding steht im Keller – ohne Monitor.

Also erst mal Monitor, Tastatur und Maus in den Keller geschleppt und nachgeschaut.

Schwarzer Bildschirm.

Deckel auf, tatsächlich da war noch eine 3TB Seagate-Platte drin. Die wurde aber nicht mehr angezeigt.

Defekte Platte ausgebaut, neu gestartet – Windows startet, lädt, schwarzer Bildschirm. Mehr tut sich nicht.

Verschiedene Optionen durchprobiert, trotz SSD ziemlich langwierig und langweilig.

Mist!

18.00 Uhr: Webseite offline, Server tot.

Eigentlich wollte ich heute noch was anderes machen.

 

RECOVERY

Tja, der wichtige Server-Teil ist eine virtuelle Linux-Maschine und das Backup war gerade mal 10 Minuten alt.

Den Windows-Server (Server 2008) wollte ich sowieso ausser Dienst stellen (HP ML110 – groß und stromhungrig, für die Webseite völlig überdimensioniert – früher lief da mehr (EDV-Service mache ich ja nicht mehr). Der lief nur noch als Host für die Linux-VM und für ein paar kleinere Progrämmchen.

Am PC mal das Backup-Image angeschaut, die Virtuelle Linux-Maschine war nur eine Datei, allerdings 160GB. Die mal eben auf einen anderen PC kopieren war garnicht so einfach, denn da hatte ich überall nur kleine SSD und am Bastelrechner den ich als vorübergehenden Host nehmen wollte war nicht genug Platz frei.

Auf dem Druckrechner war genug frei, allerdings lief da Windows 10.

Das Recovery der Linuxkiste ging schnell:

Kurz Virtualbox installiert und – nur 32Bit VM möglich, das Linux läuft aber mit 64bit.

Lösung: Windows 10 hat selbst bereits Hyper-V integriert und in der aktuellen Version ist das auch gleich aktiviert. Deaktivieren ist aber garnicht so einfach und im Bios muss man dazu auch was ändern. Bios heisst aber “direkt am PC und nicht per Remote-Desktop”, hm, auch der Rechner hatte eigentlich keinen Monitor und der Bastel-Monitor stand ja jetzt im Keller. Ärgerlich. Und ausserdem – das ist meine Haupt-Arbeitsmaschine, wenn die nicht läuft verdiene ich nichts. Also besser nicht anfassen.

Muss ja nicht noch ein System zerlegen.

Dann doch der Bastel-Rechner. Windows 7/64bit ist einfach fein. Zwar alt aber es tut einfach.

Aber ob das auch über das Netzwerk funktioniert?

Ja – funktioniert, Virtualbox installiert, VM eingespielt, IP-Adresse angepasst (hatte sich wegen der geänderten Netzwerkschnittstelle auf dem neuen PC geändert) und läuft!

Perfekt, die Webseite ist wieder online 🙂

Kaum 2 Stunden Lebenszeit verbraten, davon alleine über eine Stunde nur fürs Kopieren.

Da hat mein Kabelanbieter mit knapp 24 Stunden Systemausfall (im ganzen Ort!) vorletzte Woche deutlich mehr Zeit benötigt.

Ich bin zufrieden. Keine Daten verloren.

 

Was noch fehlt:

  • Die Anzeige der Photovoltaik-Leistung – aber aktuell scheint ja sowieso kaum die Sonne – der Datenlogger ist ein Windows-Programm
  • Anzeige der Radioaktiven Umgebungsstrahlung – wird heute schon keinen GAU geben – Eigenbau mit Windows-Software
  • Mail-Archivierung mit Mailstore geht nicht – Windows-Software.

Das waren 3 Dinge die lokal noch auf der Windows-Maschine liefen – ohne Virtualisierung.

Die Funktionen baue ich wieder ein wenn das Ersatzgerät da ist. Ist nicht ganz so dringend.

 

Ersatzmaschine

Nicht ganz so einfach wie das Restore gestaltet sich aber die Suche nach einer Ersatzmaschine.

Denn für aktuelle Boards gibt es keine Windows 7 Treiber mehr.

Das ist ärgerlich. Denn eine Windows 7-Lizenz habe ich noch übrig, Windows 10 nicht.

Und überhaupt Windows 10 ist nicht für den Dauerbetrieb geeignet, das startet gerne mal neu wenn es sich unbeaufsichtigt fühlt. Einfach mal zwischendurch Updates einspielen und am besten beim Neustart hängenbleiben – schon mehrfach passiert. Ausschalten lässt sich dieser automatische Update-Mist leider nicht. Nur verschieben, dann passiert es halt etwas später. Dazu die ganzen Cloud- und Spionage-Einstellungen. Nein Windows 10 ist nicht mein Freund.

Der angedachte Mini-PC Intel NUC713BNH war daher leider nicht möglich, dafür gibts nämlich keine Windows-7-Treiber mehr. Ärgerlich.  Linux ist auch nicht möglich da ich mit meiner Radioaktivitäts-Messung und der Photovoltaik-Anlage noch Programme habe die nur mit Windows laufen, dafür benötige ich leider noch Windows.  Der NUC5CPYH wäre kompatibel,  ist  supergünstig aber auch superlangsam.

Die Entscheidung fiel daher auf den NUC5I3RYH – zwar auch schon ein älteres Modell und leider zum gleichen Preis wie das aktuelle Gerät. Aber immerhin kompatibel zu Windows 7 und – ich habe die gleiche Maschine bereits im Einsatz. Da weiß ich daß es funktioniert.

Am Freitag soll alles angeliefert werden, bis dahin läuft die Webseite erst mal auf dem Bastelrechner mit dem Festplattenimage über das Netzwerk.

Falls was kaputt geht fällt im schlimmsten Fall alles auf den 30.11. 17.50 zurück.

Dann ist halt dieser eine Blog-Beitrag verloren.

Ich werde weiter berichten…

Jetzt ist 1 Uhr, gute Nacht!

 

PS.: Datensicherung nicht vergessen!

 

Ein paar Tage später…

der Webserver läuft problemlos.
Für Web-Zugriffe merkt man keinen Unterschied zwischen dem i3 im NUC und dem XEON 1230 vorher im ML110. Im Gegenteil, das System scheint deutlich schneller zu reagieren. Vielleicht war auf dem alten Server mittlerweile einfach zuviel Müll installiert.

Der Geigerzähler funktioniert auch wieder. Hat noch einen USB-Seriell-Wandler erfordert. Zum Glück war noch einer in der Bastelkiste.

Der Photovoltaik-Logger funktioniert ebenfalls. Wobei im Augenblick fast durchgehend dunkel ist.

Der Stromverbrauch hat sich von über 60W auf ca. 10W verringert, das ist aufs Jahr gerechnet eine Menge.

Das neue NAS 918+ läuft ebenfalls problemlos. Insgesamt bin ich mit der Umstellung zufrieden.

 

 

Schreibe einen Kommentar

Your email address will not be published.